Support Team Connection Issues
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Jul 10, 2023 - 16:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2023 - 15:55 EDT
Update
Our team have applied a fix and our support queues are back to normal.
Thank you for your patience.
Posted Jul 10, 2023 - 15:55 EDT
Investigating
We are currently experiencing technical difficulties, our support queues will be closed for a time until we resolve this matter. We apologize for the inconvenience and thank you for your patience.
Posted Jul 10, 2023 - 13:32 EDT