Customers report they are not able to connect via chat/messaging and voice.

Incident Report for Internic Status Page

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 14:52 EDT

Update

Zendesk has corrected the issue. Closing this notification.
Posted Mar 24, 2025 - 14:51 EDT

Investigating

Zendesk reports they are experiencing a widespread outage effecting both phone and chat/messaging services. Due to this we are having issues connecting with our customers. Once Zendesk has corrected the problem we will resume business as usual. To contact us for a quicker response, please email.
Posted Mar 21, 2025 - 08:41 EDT