Classic Hosting Email Issue Notification

Incident Report for Internic Status Page

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 09:28 EDT

Monitoring

The issue has been identified and a fix has been implemented. We will continue to monitor the results.
Posted Mar 11, 2023 - 12:19 EST

Investigating

We are currently aware of an issue with the Classic hosting email server that is preventing users from sending email. Our team is working hard to resolve this issue as soon as possible and will provide further updates here when available. We apologize for any inconvenience this may have caused.
Posted Mar 11, 2023 - 11:08 EST