Service Centre Disruption
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted May 26, 2022 - 11:04 EDT
Investigating
Please note that our Customer Service Centre is currently offline due to power outages caused by severe thunderstorms. We hope to be back online shortly.

Important: No other services (e.g., hosting) should be affected by this outage. Only our Customer Service team's ability to handle live interactions is affected. You can still email questions to service@internic.ca
Posted May 21, 2022 - 16:34 EDT