Access issues with Cloud Email
Incident Report for Internic Status Page
Resolved
There was a resource contention issue discovered and fixed on the platform. We have been monitoring and there have been no issues detected since the fix.
Posted Aug 03, 2023 - 12:54 EDT
Investigating
Our team are investigating some access issues with Cloud Email. We will follow with updates.

We apologize for any inconvenience.
Posted Aug 02, 2023 - 11:05 EDT