Phone Routing Issues

Incident Report for Internic Status Page

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 14:05 EST

Investigating

We’re currently investigating an issue affecting inbound and outbound phone routing for Internic Support. Calls may not connect properly or may experience longer than normal wait times.

Workaround:
Our Support Team remains fully available by email — for the fastest response, please reach us at:
service@internic.ca

Next Update:
We’ll share another update once phone service has been restored or more details are available.

Thank you for your patience and understanding.

— The Internic Support Team
Posted Oct 29, 2025 - 10:48 EDT