Reports of clients not able to access domain edit page
Incident Report for Internic Status Page
Resolved
Thank you for your patience, this incident is resolved.
Posted Nov 12, 2024 - 11:32 EST
Investigating
Our team are investigating reports of users not able to access the domain edit page. This is urgent priority and will be resolved as soon as possible.
Posted Nov 12, 2024 - 10:57 EST