Customers are unable to connect with support via Voice

Incident Report for Internic Status Page

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 10:08 EDT

Investigating

We have logged an incident with Zendesk. Will update soon.
Posted Apr 01, 2025 - 10:08 EDT