2FA code slow to deliver

Incident Report for Internic Status Page

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 14:21 EDT

Identified

WE have identified an issue with the 2FA code slow to deliver to the email of record. We are working to correct this ASAP
Posted Jun 11, 2025 - 12:27 EDT