SSL certificate expired - imap.internic.ca / smtp.internic.ca / mail.internic.ca
Incident Report for Internic Status Page
Resolved
The Cloud Email SSL error is resolved. Thank you for your patience.
Posted Jul 20, 2023 - 07:56 EDT
Identified
Update on Cloud Email SSL - Cloud webmail mail.internic.ca is secure and functional now. Our team are working on resolving the IMAP / POP and SMTP issue as soon as possible. Thank you.
Posted Jul 19, 2023 - 08:09 EDT
Investigating
The SSL certificate expired for imap.internic.ca / smtp.internic.ca / mail.internic.ca

Our team are working to resolve the issue.

We apologize for any inconvenience.
Posted Jul 18, 2023 - 11:41 EDT