Issues Adding American Express Credit Cards to Accounts
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 11:33 EDT
Investigating
We are currently investigating issues with our system not accepting American Express (AMEX) credit cards. We are working with our Merchant Services provider to resolve the issue as soon as possible. Please note that Internic does offer Paypal as a payment method and that this issue should not prevent you from being able to link your AMEX to your Paypal account, if you require an alternative way of making payments.
Posted Jun 06, 2021 - 11:57 EDT