Service Queues Closed from 2:30PM - 4:30PM (Eastern)
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 16:56 EST
Identified
Our live service queues (chat and phone) will be closed from 2:30PM - 4::30PM (Eastern) for a company-wide meeting. You may still email us or leave us a voice mail with any inquiries you may have and we'll get back to you as soon as possible. We apologize for the inconvenience and thank you for your patience.
Posted Jan 22, 2021 - 11:20 EST