Live Service Queues Closed from 2:30PM - 4:30PM (Eastern)
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Jan 18, 2021 - 08:46 EST
Update
The meeting has concluded and the queues are open.
Posted Jan 15, 2021 - 16:31 EST
Investigating
Our queues will be closed from 2:30-4:30PM (Eastern) for a company-wide meeting. You may leave a voicemail or email us and we'll get back to you as soon as possible.
Posted Jan 15, 2021 - 14:31 EST