Classic (Clustered) Hosting / Professional Email - Sending Duplicate Emails
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 10:10 EST
Investigating
We are currently investigating reports that when using 3rd party email clients (e.g., Outlook) with our Classic (Clustered) Hosting / Professional Email, customers are seeing multiple copies of their emails being sent to the intended recipients. Because this issue is related to how a 3rd party product interacts with our system, resolving the issue may take more time than if the issue was limited to our system. We are compiling every available example in an effort to resolve the issue as soon as possible. You can try sending emails directly from our servers via webmail.internic.ca to avoid email duplication. We apologize for the inconvenience and thank you for your patience.
Posted Sep 01, 2022 - 16:54 EDT