Issue Navigating Within Hosting Manager
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 08:57 EST
Identified
We believe that we have a fix in place. We are currently testing it. We expect it to be released later this morning. We thank you for your patience.
Posted Nov 27, 2020 - 05:27 EST
Investigating
We have identified an issue that is causing drop-down menus to fail while navigating the hosting manager. Our team is working to resolve this issue as soon as possible.
Posted Nov 26, 2020 - 17:50 EST