Hosting Server Issue Notification
Incident Report for Internic Status Page
Resolved
This incident has been resolved.
Posted May 26, 2022 - 11:05 EDT
Investigating
We are aware of an issue on our hosting server, canada1-mw.internic.ca that is resulting in some customers being unable to access or manage their website. Our team is working hard to resolve this issue as soon as possible and will provide further updates here when available. We apologize for any inconvenience this may have caused.
Posted May 21, 2022 - 15:41 EDT